summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-13 11:17:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-13 11:17:43 +0100
commitcf2251b9f7a53a3303ea71d197bef4a96997a4c3 (patch)
tree6cc6d01101abe9aa6c8dd7adcc98d55104a1e6e7 /gnu/packages/bioconductor.scm
parent73d2fb94e30b5b179a557a07a42f905d8dcf40e0 (diff)
downloadguix-patches-cf2251b9f7a53a3303ea71d197bef4a96997a4c3.tar
guix-patches-cf2251b9f7a53a3303ea71d197bef4a96997a4c3.tar.gz
gnu: Add r-sanssouci.
* gnu/packages/bioconductor.scm (r-sanssouci): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3f02ec527a..44bf5c7d24 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6852,6 +6852,37 @@ required source code files from the official Leidenalg distribution and
several functions from the R igraph package.")
(license license:gpl3+))))
+(define-public r-sanssouci
+ ;; sansscouci doesn't have a (versioned) release yet.
+ ;; This is the latest commit as of packaging for Guix.
+ (let ((commit "5fe20a9aaf4ac637fa83d9cc73ff1c22de97ca6f")
+ (revision "1"))
+ (package
+ (name "r-sanssouci")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pneuvial/sanssouci.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "13ycdd790qw64qy2zdvcrpj3fc8as628rsly32438d3rifnlc5sk"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-generics" ,r-generics)
+ ("r-matrix" ,r-matrix)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page "https://pneuvial.github.io/sanssouci")
+ (synopsis "Post Hoc multiple testing inference")
+ (description
+ "The goal of sansSouci is to perform post hoc inference: in a multiple
+testing context, sansSouci provides statistical guarantees on possibly
+user-defined and/or data-driven sets of hypotheses.")
+ (license license:gpl3))))
+
(define-public r-monocle3
(package
(name "r-monocle3")