summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2021-10-30 17:55:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-11-27 10:36:27 +0100
commitc96d8ce7208ea032383811b9b79dc57ce0e3ba07 (patch)
tree15200e92c56d7f14c5777639049ba16aebe636b4 /gnu/packages/bioconductor.scm
parentfefdea2a1ae1534ccc7011f2d2ac6ed0ab2925e8 (diff)
downloadguix-patches-c96d8ce7208ea032383811b9b79dc57ce0e3ba07.tar
guix-patches-c96d8ce7208ea032383811b9b79dc57ce0e3ba07.tar.gz
gnu: Add r-stringdb.
* gnu/packages/bioconductor.scm (r-stringdb): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3dc8c61c4e..527e549bc6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4386,6 +4386,39 @@ events and allows for the incorporation of prior knowledge through supervised
graph construction.")
(license license:artistic2.0)))
+(define-public r-stringdb
+ (package
+ (name "r-stringdb")
+ (version "2.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "STRINGdb" version))
+ (sha256
+ (base32 "1hvb73anhbf1g82nn5m11s783z6ihvlavf7p30w29qggxggnl6lm"))))
+ (properties `((upstream-name . "STRINGdb")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gplots" ,r-gplots)
+ ("r-hash" ,r-hash)
+ ("r-igraph" ,r-igraph)
+ ("r-plotrix" ,r-plotrix)
+ ("r-plyr" ,r-plyr)
+ ("r-png" ,r-png)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rcurl" ,r-rcurl)
+ ("r-sqldf" ,r-sqldf)))
+ (home-page "https://git.bioconductor.org/packages/STRINGdb")
+ (synopsis "Search tool for the retrieval of interacting proteins database")
+ (description
+ "The @code{STRINGdb} package provides an R interface to the STRING
+protein-protein interactions database. @url{https://www.string-db.org,
+STRING} is a database of known and predicted protein-protein interactions.
+The interactions include direct (physical) and indirect (functional)
+associations. Each interaction is associated with a combined confidence score
+that integrates the various evidences.")
+ (license license:gpl2)))
+
(define-public r-structuralvariantannotation
(package
(name "r-structuralvariantannotation")