summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-17 19:47:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-17 20:02:17 +0100
commit75a8bb31859b217e4864c96ecde0019b69c17280 (patch)
treeb9571637462fc60dd0651b6152130b5cdee0ed00 /gnu/packages/bioconductor.scm
parente823337c6eb9ab99e0e3311d4c8024cb220afd08 (diff)
downloadguix-patches-75a8bb31859b217e4864c96ecde0019b69c17280.tar
guix-patches-75a8bb31859b217e4864c96ecde0019b69c17280.tar.gz
gnu: Add r-hypergraph.
* gnu/packages/bioconductor.scm (r-hypergraph): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4e7bfc582a..eeffafc51c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6706,3 +6706,25 @@ the read count and GC content bias.")
"This package provides an R interface to libsbml for SBML parsing,
validating output, provides an S4 SBML DOM, converts SBML to R graph objects.")
(license license:artistic2.0)))
+
+(define-public r-hypergraph
+ (package
+ (name "r-hypergraph")
+ (version "1.58.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "hypergraph" version))
+ (sha256
+ (base32
+ "1bixmslxy7r987zw1vf4dg72hfi04lf4vj03n7ygym2g8nfhbh7m"))))
+ (properties `((upstream-name . "hypergraph")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-graph" ,r-graph)))
+ (home-page "https://bioconductor.org/packages/hypergraph")
+ (synopsis "Hypergraph data structures")
+ (description
+ "This package implements some simple capabilities for representing and
+manipulating hypergraphs.")
+ (license license:artistic2.0)))