summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-07-04 17:44:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-05 15:08:44 +0200
commit5da0e1428568be137054cb1fe220c28cd42f9eec (patch)
tree86ec73f34b5e00c3bbef3850bac3beb6cae6950e /gnu/packages/bioconductor.scm
parent27c51606ae44f682dfba5363757bead223b57c5d (diff)
downloadguix-patches-5da0e1428568be137054cb1fe220c28cd42f9eec.tar
guix-patches-5da0e1428568be137054cb1fe220c28cd42f9eec.tar.gz
gnu: Add r-goseq.
* gnu/packages/bioconductor.scm (r-goseq): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 882e3e14dd..40ac1d2015 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -724,3 +724,29 @@ information and producing various plots and statistics.")
"This package provides tools for exporting and importing classification
trees and clusters to other programs.")
(license license:gpl2)))
+
+(define-public r-goseq
+ (package
+ (name "r-goseq")
+ (version "1.32.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "goseq" version))
+ (sha256
+ (base32
+ "0xmbb8ma32lrfy810r82y34gkspq4fqiqxykic9j4rq9rg9n9x2l"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biasedurn" ,r-biasedurn)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-genelendatabase" ,r-genelendatabase)
+ ("r-go-db" ,r-go-db)
+ ("r-mgcv" ,r-mgcv)))
+ (home-page "https://bioconductor.org/packages/goseq/")
+ (synopsis "Gene Ontology analyser for RNA-seq and other length biased data")
+ (description
+ "This package provides tools to detect Gene Ontology and/or other user
+defined categories which are over/under represented in RNA-seq data.")
+ (license license:lgpl2.0+)))