summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-13 10:54:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-13 10:54:05 +0100
commit495646aa73522e0a204504967d5b638e9cc81756 (patch)
treeb4da4d9b1799b26a72ee61e820bce9137ee94976 /gnu/packages/bioconductor.scm
parent531a69ecb6ac85d03230d242b739c9671c984d0a (diff)
downloadguix-patches-495646aa73522e0a204504967d5b638e9cc81756.tar
guix-patches-495646aa73522e0a204504967d5b638e9cc81756.tar.gz
gnu: Add r-drimseq.
* gnu/packages/bioconductor.scm (r-drimseq): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ee3ce80f9c..5a67f6dbbd 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1668,6 +1668,41 @@ spent loading the full derfinder package when running the F-statistics
calculation in parallel.")
(license license:artistic2.0)))
+(define-public r-drimseq
+ (package
+ (name "r-drimseq")
+ (version "1.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DRIMSeq" version))
+ (sha256
+ (base32 "0y2jb0hb633id038zmwnfny6h4ai77fdyy02f77vha1z8xg5nl02"))))
+ (properties `((upstream-name . "DRIMSeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-edger" ,r-edger)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-iranges" ,r-iranges)
+ ("r-limma" ,r-limma)
+ ("r-mass" ,r-mass)
+ ("r-reshape2" ,r-reshape2)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/DRIMSeq")
+ (synopsis "Differential transcript usage and tuQTL analyses with Dirichlet-multinomial model in RNA-seq")
+ (description
+ "The package provides two frameworks. One for the differential
+transcript usage analysis between different conditions and one for the tuQTL
+analysis. Both are based on modeling the counts of genomic features (i.e.,
+transcripts) with the Dirichlet-multinomial distribution. The package also
+makes available functions for visualization and exploration of the data and
+results.")
+ (license license:gpl3+)))
+
(define-public r-bluster
(package
(name "r-bluster")