summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-17 19:47:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-17 20:02:17 +0100
commit40fe63ad8a3578a2a7090ee18fcb3d35096ba8c8 (patch)
treeebda752b068aed26cd6539042d4ad9f708bbe71d /gnu/packages/bioconductor.scm
parentde9374b73cc14245d41d4944c0632a804fe52efb (diff)
downloadguix-patches-40fe63ad8a3578a2a7090ee18fcb3d35096ba8c8.tar
guix-patches-40fe63ad8a3578a2a7090ee18fcb3d35096ba8c8.tar.gz
gnu: Add r-bifet.
* gnu/packages/bioconductor.scm (r-bifet): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 896d451bac..beb46c9ded 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6650,3 +6650,31 @@ algorithm which is more efficient for larger data sets.")
"This is a package for biclustering analysis and exploration of
results.")
(license license:gpl2)))
+
+(define-public r-bifet
+ (package
+ (name "r-bifet")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiFET" version))
+ (sha256
+ (base32
+ "0ck1d6hxd4f40hfz8p2z5xmjbz79yhrf6fisjka2xzk5v9fm4p4k"))))
+ (properties `((upstream-name . "BiFET")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-genomicranges" ,r-genomicranges)
+ ("r-poibin" ,r-poibin)))
+ (home-page "https://bioconductor.org/packages/BiFET")
+ (synopsis "Bias-free footprint enrichment test")
+ (description
+ "BiFET identifies @dfn{transcription factors} (TFs) whose footprints are
+over-represented in target regions compared to background regions after
+correcting for the bias arising from the imbalance in read counts and GC
+contents between the target and background regions. For a given TF k, BiFET
+tests the null hypothesis that the target regions have the same probability of
+having footprints for the TF k as the background regions while correcting for
+the read count and GC content bias.")
+ (license license:gpl3)))