summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorMalte Frank Gerdes <malte.f.gerdes@gmail.com>2020-10-23 15:11:52 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-26 22:56:29 +0100
commitd1ecb3bded7ddbbccd9a8720a9aa8cf10809fa5e (patch)
treee8bc6dd9f32491370820cec645b0e5f746436be8 /gnu/packages/benchmark.scm
parent0be00efff5d5e138c356464060fc47b7a5c47e28 (diff)
downloadguix-patches-d1ecb3bded7ddbbccd9a8720a9aa8cf10809fa5e.tar
guix-patches-d1ecb3bded7ddbbccd9a8720a9aa8cf10809fa5e.tar.gz
gnu: benchmark: Update to 1.5.2
* gnu/packages/benchmark.scm (benchmark): Update to 1.5.2 [native-inputs]: Add googletest-source. [arguments]: Add phase 'unpack-googletest. * gnu/packages/patches/benchmark-unbundle-googletst.patch: Delete file. * gnu/packages/local.mk: Remove benchmark-unbundle-googletest.patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index f9648b5f7c..8a8309ce52 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -213,7 +214,7 @@ This can give a much better understanding of the command's performance.")
(define-public benchmark
(package
(name "benchmark")
- (version "1.5.0")
+ (version "1.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -222,16 +223,24 @@ This can give a much better understanding of the command's performance.")
(file-name (git-file-name name version))
(sha256
(base32
- "0r9dbg4cbk47gwmayys31a83m3y67k0kh1f6pl8i869rbd609ndh"))
- (patches (search-patches "benchmark-unbundle-googletest.patch"))))
+ "13rxagpzw6bal6ajlmrxlh9kgfvcixn6j734b2bvfqz7lch8n0pa"))))
(build-system cmake-build-system)
(native-inputs
- `(("googletest" ,googletest)))
+ `(("googletest-source" ,(package-source googletest))
+ ("googletest" ,googletest)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-googletest
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "googletest-source")
+ "googletest")
+ #t)))))
(home-page "https://github.com/google/benchmark")
(synopsis "Microbenchmark support library")
(description
- "Benchmark is a library to benchmark code snippets,
-similar to unit tests.")
+ "Benchmark is a library to benchmark code snippets, similar to unit
+tests.")
(license license:asl2.0)))
(define-public bonnie++