summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-03 20:08:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-03 23:26:21 +0200
commit90b86970eb6a024354a85e8dfa2d294bbda39162 (patch)
treed146de0b634feebadbfd9533d186adfca7c8d474 /gnu/packages/benchmark.scm
parentdde56d8377d41a13371fe5a95feec719427e84c9 (diff)
downloadguix-patches-90b86970eb6a024354a85e8dfa2d294bbda39162.tar
guix-patches-90b86970eb6a024354a85e8dfa2d294bbda39162.tar.gz
gnu: benchmark: Update to 1.5.6.
* gnu/packages/benchmark.scm (benchmark): Update to 1.5.6. [arguments]: Don't return #t from phases.
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index b8f5d7f687..93be96eb85 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -222,7 +222,7 @@ This can give a much better understanding of the command's performance.")
(define-public benchmark
(package
(name "benchmark")
- (version "1.5.5")
+ (version "1.5.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -231,7 +231,7 @@ This can give a much better understanding of the command's performance.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ijv4idcjsyy61dab59ywbx0xdbws44kxgqjr1ylaxzwknh745qf"))))
+ "030g4d8vpn2442dsap0qw86lsw7xfl36k0x0x9bn0vvm11qvjn8c"))))
(build-system cmake-build-system)
(native-inputs
`(("googletest-source" ,(package-source googletest))
@@ -242,8 +242,7 @@ This can give a much better understanding of the command's performance.")
(add-after 'unpack 'unpack-googletest
(lambda* (#:key inputs #:allow-other-keys)
(copy-recursively (assoc-ref inputs "googletest-source")
- "googletest")
- #t)))))
+ "googletest"))))))
(home-page "https://github.com/google/benchmark")
(synopsis "Microbenchmark support library")
(description