summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-19 00:25:18 +0100
committerMarius Bakke <marius@gnu.org>2022-01-19 10:05:30 +0100
commit8d70f509c700a66a6b94ff42aa0db53d582dfb53 (patch)
tree3170f1f9cf073072e66ee065979b0777ee2c4d3b /gnu/packages/benchmark.scm
parent312686ac5f5c17eb66feb4f56c3f3bfae7ffb512 (diff)
downloadguix-patches-8d70f509c700a66a6b94ff42aa0db53d582dfb53.tar
guix-patches-8d70f509c700a66a6b94ff42aa0db53d582dfb53.tar.gz
gnu: python-locust: Update to 2.5.1.
* gnu/packages/benchmark.scm (python-locust): Update to 2.5.1. [arguments]: Remove obsolete phase. Respect TESTS? in check phase. [native-inputs]: Add PYTHON-RETRY and PYTHON-SETUPTOOL-SCM. [propagated-inputs]: Add PYTHON-FLASK-CORS, PYTHON-ROUNDROBIN, and PYTHON-TYPING-EXTENSIONS.
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm61
1 files changed, 29 insertions, 32 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 817e6b1957..537f6262c4 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -254,60 +254,57 @@ file metadata operations that can be performed per second.")
(define-public python-locust
(package
(name "python-locust")
- (version "1.4.3")
+ (version "2.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "locust" version))
(sha256
(base32
- "0vmw151xcaznd2j85n96iyv9fniss0bkk91xn4maw2gwzym424xk"))))
+ "1516z6z5pikybg7pma2cgxgj3wxaaky7z6d30mxf81wd4krbq16s"))))
(build-system python-build-system)
(arguments
- `(#:phases
+ '(#:phases
(modify-phases %standard-phases
- (add-before 'check 'extend-PATH
- ;; Add the 'locust' script to PATH, which is used in the test
- ;; suite.
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "PATH" (string-append out "/bin:"
- (getenv "PATH"))))))
(replace 'check
- (lambda _
- (invoke "python" "-m" "pytest"
- "-k" (string-join
- (list
- ;; These tests return "non-zero exit status 1".
- "not test_default_headless_spawn_options"
- "not test_default_headless_spawn_options_with_shape"
- "not test_headless_spawn_options_wo_run_time"
- ;; These tests depend on networking.
- "not test_html_report_option"
- "not test_web_options"
- ;; This test fails because of the warning "System open
- ;; file limit '1024' is below minimum setting '10000'".
- "not test_skip_logging"
- ;; On some (slow?) machines, the following tests
- ;; fail, with the processes returning exit code
- ;; -15 instead of the expected 42 and 0,
- ;; respectively (see:
- ;; https://github.com/locustio/locust/issues/1708).
- "not test_custom_exit_code"
- "not test_webserver") " and ")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "locust"
+ "-k" (string-join
+ '(;; These tests return "non-zero exit status 1".
+ "not test_default_headless_spawn_options"
+ "not test_default_headless_spawn_options_with_shape"
+ "not test_headless_spawn_options_wo_run_time"
+ ;; These tests depend on networking.
+ "not test_html_report_option"
+ "not test_web_options"
+ ;; This test fails because of the warning "System open
+ ;; file limit '1024' is below minimum setting '10000'".
+ "not test_skip_logging"
+ ;; On some (slow?) machines, the following tests
+ ;; fail, with the processes returning exit code
+ ;; -15 instead of the expected 42 and 0,
+ ;; respectively (see:
+ ;; https://github.com/locustio/locust/issues/1708).
+ "not test_custom_exit_code"
+ "not test_webserver") " and "))))))))
(propagated-inputs
(list python-configargparse
python-flask
python-flask-basicauth
+ python-flask-cors
python-gevent
python-geventhttpclient
python-msgpack
python-psutil
python-pyzmq
python-requests
+ python-roundrobin
+ python-typing-extensions
python-werkzeug))
(native-inputs
- (list python-mock python-pyquery python-pytest)) ;for more easily skipping tests
+ (list python-mock python-pyquery python-pytest
+ python-retry python-setuptools-scm))
(home-page "https://locust.io/")
(synopsis "Distributed load testing framework")
(description "Locust is a performance testing tool that aims to be easy to