summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-11-06 00:09:30 +0100
committerMarius Bakke <marius@gnu.org>2021-11-06 17:46:37 +0100
commit290a7664b58d2a018096c6388ae3468eb4cd88ec (patch)
tree052b73558fd55db98d0d3457728c6204dee155ed /gnu/packages/benchmark.scm
parent75f2eb41ccd21fd38dc371830d93fc63083a83b4 (diff)
downloadguix-patches-290a7664b58d2a018096c6388ae3468eb4cd88ec.tar
guix-patches-290a7664b58d2a018096c6388ae3468eb4cd88ec.tar.gz
gnu: fio: Disable native CPU compiler optimizations.
* gnu/packages/benchmark.scm (fio)[arguments]: Add #:configure-flags. Adjust configure phase accordingly.
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index e355a47d4e..9741814c82 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -65,15 +65,17 @@
`(#:modules (,@%gnu-build-system-modules
(ice-9 textual-ports))
#:test-target "test"
+ #:configure-flags '("--disable-native") ;don't generate code for the build CPU
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key (configure-flags ''()) outputs #:allow-other-keys)
;; The configure script doesn't understand some of the
- ;; GNU options, so we can't use #:configure-flags.
+ ;; GNU options, so we can't use the stock phase.
(let ((out (assoc-ref outputs "out")))
- (invoke "./configure"
- (string-append "--prefix=" out)))))
+ (apply invoke "./configure"
+ (string-append "--prefix=" out)
+ configure-flags))))
;; The main `fio` executable is fairly small and self contained.
;; Moving the auxiliary scripts to a separate output saves ~100 MiB
;; on the closure.