summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 11:37:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:19 +0100
commit1530b17aa14df91399f2dab0f5ee7951e27c6071 (patch)
treefcd7ecdcf62dfe51305aaba381e7366022808028 /gnu/packages/benchmark.scm
parent843ce5b41939f213e588921d5a8e11e4051b4e40 (diff)
downloadguix-patches-1530b17aa14df91399f2dab0f5ee7951e27c6071.tar
guix-patches-1530b17aa14df91399f2dab0f5ee7951e27c6071.tar.gz
gnu: imb: Use INVOKE.
* gnu/packages/benchmark.scm (imb)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index e97e827cea..c670a9af1c 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -135,10 +135,9 @@ is to write a job file matching the I/O load one wants to simulate.")
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
(let ((mpi-home (assoc-ref inputs "mpi")))
- (zero?
- ;; Not safe for parallel build
- (system* "make" "-C" "imb/src" "-f" "make_mpich" "SHELL=sh"
- (string-append "MPI_HOME=" mpi-home))))))
+ ;; Not safe for parallel build
+ (invoke "make" "-C" "imb/src" "-f" "make_mpich" "SHELL=sh"
+ (string-append "MPI_HOME=" mpi-home)))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))