summaryrefslogtreecommitdiff
path: root/gnu/packages/bdw-gc.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-12-20 16:23:25 -0600
committerEric Bavier <bavier@member.fsf.org>2016-01-02 16:06:11 -0600
commit8d0801ab235a6083c17235cefc214eb0537ffc1e (patch)
treeaf959ee58c2380ba1c859e49f543df26afc4c012 /gnu/packages/bdw-gc.scm
parente80d2555f5dfa89cd44b261ead2c5fd397a51f56 (diff)
downloadguix-patches-8d0801ab235a6083c17235cefc214eb0537ffc1e.tar
guix-patches-8d0801ab235a6083c17235cefc214eb0537ffc1e.tar.gz
gnu: libgc: Enable C++ support.
* gnu/packages/bdw-gc.scm (libgc-7.2, libgc)[arguments]: Add --enable-cplusplus to #:configure-flags.
Diffstat (limited to 'gnu/packages/bdw-gc.scm')
-rw-r--r--gnu/packages/bdw-gc.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index 66158912d7..0a483ef864 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -39,7 +39,9 @@
(arguments
;; Make it so that we don't rely on /proc. This is especially useful in
;; an initrd run before /proc is mounted.
- '(#:configure-flags '("CPPFLAGS=-DUSE_LIBC_PRIVATES")))
+ '(#:configure-flags '("CPPFLAGS=-DUSE_LIBC_PRIVATES"
+ ;; Install gc_cpp.h et al.
+ "--enable-cplusplus")))
(outputs '("out" "debug"))
(synopsis "The Boehm-Demers-Weiser conservative garbage collector
for C and C++")
@@ -103,4 +105,4 @@ lock-free code, experiment with thread programming paradigms, etc.")
(inputs `(("libatomic-ops" ,libatomic-ops)))
;; 'USE_LIBC_PRIVATES' is now the default.
- (arguments '())))
+ (arguments '(#:configure-flags '("--enable-cplusplus")))))