summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-03-06 10:24:15 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-06-25 21:34:36 +0200
commitd8dbfbce60a6df9cf87ede8c0454f1b2214e80a7 (patch)
treee81512c53851eef2fa9a4ef460754fa3716cd045 /gnu/packages/bash.scm
parent6c6a049b13759c457c1d74951327e579df866900 (diff)
downloadguix-patches-d8dbfbce60a6df9cf87ede8c0454f1b2214e80a7.tar
guix-patches-d8dbfbce60a6df9cf87ede8c0454f1b2214e80a7.tar.gz
gnu: bash-completion: Fix cross-compilation.
* gnu/packages/bash.scm (bash-completion)[arguments]: Search for util-linux in native-inputs and inputs during "remove-redundant-completions" phase.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index fb4e3f4be3..ef93a11085 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -291,13 +292,16 @@ without modification.")
`(#:phases (modify-phases %standard-phases
(add-after
'install 'remove-redundant-completions
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key
+ inputs native-inputs
+ outputs #:allow-other-keys)
;; Util-linux comes with a bunch of completion files for
;; its own commands which are more sophisticated and
;; up-to-date than those of bash-completion. Remove those
;; from bash-completion.
(let* ((out (assoc-ref outputs "out"))
- (util-linux (assoc-ref inputs "util-linux"))
+ (util-linux (assoc-ref (or native-inputs inputs)
+ "util-linux"))
(completions (string-append out
"/share/bash-completion"
"/completions"))