summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2016-08-07 11:49:57 +0200
committerTomáš Čech <sleep_walker@gnu.org>2016-08-09 09:23:35 +0200
commitaa67d3c546d1023ea40e92afff3eb0703ac92032 (patch)
treefb538552de7c9ea5c0ac27608ac673f6dc13aad0 /gnu/packages/bash.scm
parentcccb4d26529c5b989b6bdb0027eab1f495aeb720 (diff)
downloadguix-patches-aa67d3c546d1023ea40e92afff3eb0703ac92032.tar
guix-patches-aa67d3c546d1023ea40e92afff3eb0703ac92032.tar.gz
gnu: bash-completion: Modify to modify-phases.
* gnu/packages/bash.scm (bash-completion): Use modify-phases instead of alist-cons-after.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index ff3acfc0e4..c006546fdd 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -289,29 +289,29 @@ without modification.")
(build-system gnu-build-system)
(native-inputs `(("util-linux" ,util-linux)))
(arguments
- `(#:phases (alist-cons-after
- 'install 'remove-redundant-completions
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Util-linux comes with a bunch of completion files for
- ;; its own commands which are more sophisticated and
- ;; up-to-date than those of bash-completion. Remove those
- ;; from bash-completion.
- (let* ((out (assoc-ref outputs "out"))
- (util-linux (assoc-ref inputs "util-linux"))
- (completions (string-append out
- "/share/bash-completion"
- "/completions"))
- (already (find-files
- (string-append
- util-linux
- "/etc/bash_completion.d"))))
- (with-directory-excursion completions
- (for-each (lambda (file)
- (when (file-exists? file)
- (delete-file file)))
- (map basename already)))
- #t))
- %standard-phases)))
+ `(#:phases (modify-phases %standard-phases
+ (add-after
+ 'install 'remove-redundant-completions
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Util-linux comes with a bunch of completion files for
+ ;; its own commands which are more sophisticated and
+ ;; up-to-date than those of bash-completion. Remove those
+ ;; from bash-completion.
+ (let* ((out (assoc-ref outputs "out"))
+ (util-linux (assoc-ref inputs "util-linux"))
+ (completions (string-append out
+ "/share/bash-completion"
+ "/completions"))
+ (already (find-files
+ (string-append
+ util-linux
+ "/etc/bash_completion.d"))))
+ (with-directory-excursion completions
+ (for-each (lambda (file)
+ (when (file-exists? file)
+ (delete-file file)))
+ (map basename already)))
+ #t))))))
(synopsis "Bash completions for common commands")
(description
"This package provides extensions that allow Bash to provide adapted