summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 10:17:40 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 10:19:22 -0400
commit8809a15389dfd8ae226af04b102facc8874947f7 (patch)
tree0d6f7887064b269e450c9d1e597ae36429606441 /gnu/packages/bash.scm
parent45413064c9db1712c845e5a1065aa81f66667abe (diff)
downloadguix-patches-8809a15389dfd8ae226af04b102facc8874947f7.tar
guix-patches-8809a15389dfd8ae226af04b102facc8874947f7.tar.gz
gnu: bash: Return #t from 'install-sh-symlink' phase.
* gnu/packages/bash.scm (bash)[arguments]: Return #t from 'install-sh-symlink' phase.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 2cc0faf190..52d93e8e7e 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -164,7 +164,8 @@ number/base32-hash tuples, directly usable in the 'patch-series' form."
;; Add a `sh' -> `bash' link.
(let ((out (assoc-ref outputs "out")))
(with-directory-excursion (string-append out "/bin")
- (symlink "bash" "sh")))))
+ (symlink "bash" "sh")
+ #t))))
(add-after 'install 'move-development-files
(lambda* (#:key outputs #:allow-other-keys)