summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/bash.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 7e98367bbb..cf40ee94f6 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -137,8 +137,7 @@ number/base32-hash tuples, directly usable in the 'patch-series' form."
(outputs '("out"
"doc" ;1.7 MiB of HTML and extra files
"include")) ;headers used by extensions
- (inputs `(("readline" ,readline)
- ("ncurses" ,ncurses))) ;TODO: add texinfo
+ (inputs (list readline ncurses)) ;TODO: add texinfo
(arguments
`(;; When cross-compiling, `configure' incorrectly guesses that job
;; control is missing.
@@ -285,7 +284,7 @@ without modification.")
(patches
(search-patches "bash-completion-directories.patch"))))
(build-system gnu-build-system)
- (native-inputs `(("util-linux" ,util-linux)))
+ (native-inputs (list util-linux))
(arguments
`(#:phases (modify-phases %standard-phases
(add-after
@@ -378,10 +377,8 @@ capturing.")
(base32
"0f59zh4d4pa1a7ybs5zl6h0csbqqv11lbnq0jl1dgwm1s6p49bsq"))))
(inputs
- `(("bash" ,bash)
- ("coreutils" ,coreutils)
- ("guile" ,guile-3.0) ;for wrap-script
- ("grep" ,grep)))
+ (list bash coreutils guile-3.0 ;for wrap-script
+ grep))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -428,14 +425,14 @@ in Bash, but you can use it to test any UNIX program.")
(base32 "0s1sifqzqmr0dnciv06yqrpzgj11d7n0gy5zaxh6b3x8bx7k75l8"))))
(build-system gnu-build-system)
(inputs
- `(("elfutils" ,elfutils)
- ("libelf" ,libelf)
- ("libffi" ,libffi)
- ("zlib" ,zlib)
- ;; Require a bash with C plugin support to build.
- ("bash" ,bash)))
+ (list elfutils
+ libelf
+ libffi
+ zlib
+ ;; Require a bash with C plugin support to build.
+ bash))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(home-page "https://github.com/taviso/ctypes.sh")
(synopsis "Foreign function interface for Bash")
(description "Bash-ctypes is a Bash plugin that provides a foreign