summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-08-15 16:45:03 -0400
committerLudovic Courtès <ludo@gnu.org>2019-09-23 23:46:48 +0200
commit567cca260d54a4515097ff3f2dc277d10ceaf613 (patch)
tree456fde9e4b55a6398b8e96b7c818bacefb01f323 /gnu/packages/bash.scm
parente5efdbce21a0afcbb3e73cc7b59111ccf62cb532 (diff)
downloadguix-patches-567cca260d54a4515097ff3f2dc277d10ceaf613.tar
guix-patches-567cca260d54a4515097ff3f2dc277d10ceaf613.tar.gz
gnu: bash: Unconditionally configure PGRP_PIPE for *-linux systems.
* gnu/packages/patches/bash-linux-pgrp-pipe.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bash.scm (bash)[source]: Add the patch.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index d3abeec6e6..f1ef7047bf 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -115,7 +115,8 @@ number/base32-hash tuples, directly usable in the 'patch-series' form."
(base32
"0kgvfwqdcd90waczf4gx39xnrxzijhjrzyzv7s8v4w31qqm0za5l"))
(patch-flags '("-p0"))
- (patches %patch-series-5.0)))
+ (patches (cons (search-patch "bash-linux-pgrp-pipe.patch")
+ %patch-series-5.0))))
(version (string-append version "." (number->string (length %patch-series-5.0))))
(build-system gnu-build-system)