summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-02 22:19:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-02 22:21:27 +0200
commit4aeb42b9f88a9191cfa5f7fed75143e0a03488c2 (patch)
tree4752b68264c2d7fb0ed9af6992278461fd67ef66 /gnu/packages/bash.scm
parentb9a30e0d37525e714a232318c26c7e4ef8250dc1 (diff)
downloadguix-patches-4aeb42b9f88a9191cfa5f7fed75143e0a03488c2.tar
guix-patches-4aeb42b9f88a9191cfa5f7fed75143e0a03488c2.tar.gz
gnu: bash: Update to patch level 2.
* gnu/packages/bash.scm (%patch-series-5.0): Add patches 1 and 2. [source]: Apply patches. [version]: Update with patch numbers.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 9fd4b30e62..4a884e6175 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -61,7 +61,8 @@
;; This is the current patches series for 5.0, generated using
;; 'download-patches' below.
(patch-series
- ))
+ (1 "12bjfdy6bg8nhyw27bdgxn7h4paylx8d927skfmi9pxd1wgrxzpj")
+ (2 "01w7yrzmz10mw06ys0546vhl7isv2v402ziyvfd7k67588spvs47")))
(define (download-patches store count)
"Download COUNT Bash patches into store. Return a list of
@@ -106,8 +107,10 @@ number/base32-hash tuples, directly usable in the 'patch-series' form."
"mirror://gnu/bash/bash-" version ".tar.gz"))
(sha256
(base32
- "0kgvfwqdcd90waczf4gx39xnrxzijhjrzyzv7s8v4w31qqm0za5l"))))
- (version version)
+ "0kgvfwqdcd90waczf4gx39xnrxzijhjrzyzv7s8v4w31qqm0za5l"))
+ (patch-flags '("-p0"))
+ (patches %patch-series-5.0)))
+ (version (string-append version "." (number->string (length %patch-series-5.0))))
(build-system gnu-build-system)
(outputs '("out"