summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2020-10-23 23:43:05 +0800
committerLudovic Courtès <ludo@gnu.org>2020-10-26 22:56:29 +0100
commit0be00efff5d5e138c356464060fc47b7a5c47e28 (patch)
treec56543a87d8559d6ce670aa2ba01154c4aac2911 /gnu/packages/bash.scm
parentaa73b41acb81c13a35d0afd272a44abe1a29c708 (diff)
downloadguix-patches-0be00efff5d5e138c356464060fc47b7a5c47e28.tar
guix-patches-0be00efff5d5e138c356464060fc47b7a5c47e28.tar.gz
gnu: Use prefix "license:" to import (guix licenses)
* gnu/packages/bash.scm (bash, bash-completion, bash-tap, bats, bash-ctypes)[license]: Rename with prefix "license:". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 2d751147fa..ed2931fd97 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -23,7 +23,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages bash)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages bootstrap)
@@ -215,7 +215,7 @@ from the Korn Shell and the C Shell and new improvements of its own. It
allows command-line editing, unlimited command history, shell functions and
aliases, and job control while still allowing most sh scripts to be run
without modification.")
- (license gpl3+)
+ (license license:gpl3+)
(home-page "https://www.gnu.org/software/bash/"))))
(define-public bash-minimal
@@ -325,7 +325,7 @@ without modification.")
"This package provides extensions that allow Bash to provide adapted
completion for many common commands.")
(home-page "https://github.com/scop/bash-completion")
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public bash-tap
(package
@@ -369,7 +369,7 @@ test library")
for Bash shell scripts and functions. Along with the Test::More-style testing
helpers it provides helper functions for mocking commands and in-process output
capturing.")
- (license expat)))
+ (license license:expat)))
(define-public bats
(package
@@ -419,7 +419,7 @@ capturing.")
framework for Bash. It provides a simple way to verify that the UNIX programs
you write behave as expected. Bats is most useful when testing software written
in Bash, but you can use it to test any UNIX program.")
- (license expat)))
+ (license license:expat)))
(define-public bash-ctypes
(package
@@ -447,4 +447,4 @@ in Bash, but you can use it to test any UNIX program.")
(description "Bash-ctypes is a Bash plugin that provides a foreign
function interface (FFI) directly in your shell. In other words, it allows
you to call routines in shared libraries from within Bash.")
- (license expat)))
+ (license license:expat)))