summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-18 15:12:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-22 18:58:05 +0100
commite9b9ea1ec0e441f413ba32391f74e96df69ad378 (patch)
tree9ef0e4cd4683d75cc2a3c4621f0ca496fb9b635c /gnu/packages/base.scm
parent5e8cb5e6980466f2571adb51f4dc5633cbd6b278 (diff)
downloadguix-patches-e9b9ea1ec0e441f413ba32391f74e96df69ad378.tar
guix-patches-e9b9ea1ec0e441f413ba32391f74e96df69ad378.tar.gz
gnu: make: Fix compatibility with glibc 2.27.
* gnu/packages/patches/make-glibc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/base.scm (gnu-make)[source](patches): Use it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 06f41284ef..bce85e8e2c 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -386,13 +386,17 @@ functionality beyond that which is outlined in the POSIX standard.")
(sha256
(base32
"12f5zzyq2w56g95nni65hc0g5p7154033y2f3qmjvd016szn5qnn"))
- (patches (search-patches "make-impure-dirs.patch"))))
+ (patches (search-patches "make-impure-dirs.patch"
+ "make-glibc-compat.patch"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config))) ; to detect Guile
(inputs `(("guile" ,guile-2.0)))
(outputs '("out" "debug"))
(arguments
- '(#:phases
+ '(;; Work around faulty glob detection with glibc 2.27. See
+ ;; <https://lists.nongnu.org/archive/html/bug-make/2017-11/msg00027.html>.
+ #:configure-flags '("make_cv_sys_gnu_glob=yes")
+ #:phases
(modify-phases %standard-phases
(add-before 'build 'set-default-shell
(lambda* (#:key inputs #:allow-other-keys)