summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-06 17:32:38 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-08 12:05:08 +0200
commitde8e2a699c0219f5ea86f6bbfff4d5ee35104738 (patch)
tree60242c1754238967ca5438c39689ed9ebaa18860 /gnu/packages/base.scm
parentd5a1206beb06678a2cb3ffcc25b687bb9fbfec74 (diff)
downloadguix-patches-de8e2a699c0219f5ea86f6bbfff4d5ee35104738.tar
guix-patches-de8e2a699c0219f5ea86f6bbfff4d5ee35104738.tar.gz
gnu: binutils: Fix file decriptor leak.
* gnu/packages/patches/binutils-2.37-file-descriptor-leak.patch: New file. * gnu/packages/local.mk (dist_patch_DATA): Add it. * gnu/packages/base.scm (binutils)[source]: Use it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index b9841a5cef..4a8fabfbad 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -510,14 +511,15 @@ change. GNU make offers many powerful extensions over the standard utility.")
(package
(name "binutils")
(version "2.37")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/binutils/binutils-"
- version ".tar.bz2"))
- (sha256
- (base32
- "1m3b2rdfv1dmdpd0bzg1hy7i8a2qng53szc6livyi3nh6101mz37"))
- (patches (search-patches "binutils-loongson-workaround.patch"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/binutils/binutils-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1m3b2rdfv1dmdpd0bzg1hy7i8a2qng53szc6livyi3nh6101mz37"))
+ (patches (search-patches "binutils-loongson-workaround.patch"
+ "binutils-2.37-file-descriptor-leak.patch"))))
(build-system gnu-build-system)
;; TODO: Add dependency on zlib + those for Gold.