summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-11 20:44:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-11 21:18:07 +0100
commitcf8264364761857ca3550398369a0f20d7b0d512 (patch)
tree9f75a82b9b18724f4bb925d145b85553403a42d3 /gnu/packages/base.scm
parentea89b62a18c988ead226cec542a5f4fdd3d58ac0 (diff)
downloadguix-patches-cf8264364761857ca3550398369a0f20d7b0d512.tar
guix-patches-cf8264364761857ca3550398369a0f20d7b0d512.tar.gz
gnu: coreutils: Update to 8.31.
* gnu/packages/base.scm (coreutils): Update to 8.31. [arguments]: Remove obsolete workaround.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c252067571..37be1ffeb7 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -300,14 +300,14 @@ used to apply commands with arbitrarily long arguments.")
(define-public coreutils
(package
(name "coreutils")
- (version "8.30")
+ (version "8.31")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/coreutils/coreutils-"
version ".tar.xz"))
(sha256
(base32
- "0mxhw43d4wpqmvg0l4znk1vm10fy92biyh90lzdnqjcic2lb6cg8"))))
+ "1zg9m79x1i2nifj4kb0waf9x3i5h6ydkypkjnbsb9rnwis8rqypz"))))
(build-system gnu-build-system)
(inputs `(("acl" ,acl) ; TODO: add SELinux
("gmp" ,gmp) ;bignums in 'expr', yay!
@@ -349,13 +349,7 @@ used to apply commands with arbitrarily long arguments.")
;; environments with long prefixes (/tmp/guix-build-...).
(substitute* "Makefile"
(("^.*tests/misc/env-S.pl.*$") ""))
- #t)))
-
- ;; Work around a cross-compilation bug whereby libcoreutils.a would
- ;; provide '__mktime_internal', which conflicts with the one in libc.a.
- ,@(if (%current-target-system)
- `(#:configure-flags '("gl_cv_func_working_mktime=yes"))
- '())))
+ #t)))))
(synopsis "Core GNU utilities (file, text, shell)")
(description
"GNU Coreutils includes all of the basic command-line tools that are