summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-17 15:48:44 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:31 -0500
commitce362bc1f35102e7d79ad7e0d638d20cef304f01 (patch)
treeea8c85669aa0f62e357221c051b170e3ef364626 /gnu/packages/base.scm
parentd3f195f77e7e617497cd3e8cbb89f6966f41b5a7 (diff)
downloadguix-patches-ce362bc1f35102e7d79ad7e0d638d20cef304f01.tar
guix-patches-ce362bc1f35102e7d79ad7e0d638d20cef304f01.tar.gz
gnu: binutils: Absorb binutils-next.
* gnu/packages/base.scm (binutils)[configure-flags]: Set out-of-source? to #t. {--enable-64-bit-bfd, --enable-compressed-debug-sections=all, --enable-lto, --enable-separate-code, --enable-threads}: New flags. (binutils-next): Delete variable. (binutils-gold): Inherit from binutils. * gnu/packages/linux.scm (kexec-tools)[native-inputs]: Replace binutils-next with binutils.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm30
1 files changed, 10 insertions, 20 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 12e4de52d4..73bdf16ea5 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -524,7 +524,8 @@ change. GNU make offers many powerful extensions over the standard utility.")
"binutils-2.37-file-descriptor-leak.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '(;; Add `-static-libgcc' to not retain a dependency
+ `(#:out-of-source? #t ;recommended in the README
+ #:configure-flags '(;; Add `-static-libgcc' to not retain a dependency
;; on GCC when bootstrapping.
"LDFLAGS=-static-libgcc"
@@ -543,7 +544,13 @@ change. GNU make offers many powerful extensions over the standard utility.")
;; Make sure 'ar' and 'ranlib' produce archives in a
;; deterministic fashion.
- "--enable-deterministic-archives")))
+ "--enable-deterministic-archives"
+
+ "--enable-64-bit-bfd"
+ "--enable-compressed-debug-sections=all"
+ "--enable-lto"
+ "--enable-separate-code"
+ "--enable-threads")))
(synopsis "Binary utilities: bfd gas gprof ld")
(description
@@ -556,23 +563,6 @@ included.")
(license gpl3+)
(home-page "https://www.gnu.org/software/binutils/")))
-;;; TODO: Merge into binutils on the next world rebuild.
-(define-public binutils-next
- (package/inherit binutils
- (name "binutils-next")
- (version "2.37")
- (arguments
- (substitute-keyword-arguments (package-arguments binutils)
- ((#:out-of-source? _ #f) ;recommended in the README
- #t)
- ((#:configure-flags flags)
- `(cons* "--enable-64-bit-bfd"
- "--enable-compressed-debug-sections=all"
- "--enable-lto"
- "--enable-separate-code"
- "--enable-threads"
- ,flags))))))
-
;; FIXME: ath9k-firmware-htc-binutils.patch do not apply on 2.34 because of a
;; big refactoring of xtensa-modules.c (commit 567607c11fbf7105 upstream).
;; Keep this version around until the patch is updated.
@@ -594,7 +584,7 @@ included.")
(properties '())))
(define-public binutils-gold
- (package/inherit binutils-next
+ (package/inherit binutils
(name "binutils-gold")
(arguments
(substitute-keyword-arguments (package-arguments binutils)