summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-06-17 07:29:30 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-06-18 09:25:20 +0200
commitc00564192a9924ab2218c243342963aba89d67d1 (patch)
tree262402f49f0706f189c2924db5af593a5e4acaf9 /gnu/packages/base.scm
parent416439263cb295260ba38ab1cce5b4468ae5691e (diff)
downloadguix-patches-c00564192a9924ab2218c243342963aba89d67d1.tar
guix-patches-c00564192a9924ab2218c243342963aba89d67d1.tar.gz
gnu: coreutils: Update broken tests for the Hurd.
* gnu/packages/base.scm (coreutils)[arguments]: When compiling for the Hurd, remove hanging "timeout-group" test. Remove tests "shred-passes", "l-chunk" and "stats" from XFAIL_TESTS, they pass now.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c66ea5a187..50e426fadf 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -342,10 +342,7 @@ used to apply commands with arbitrarily long arguments.")
(list (string-append "XFAIL_TESTS=tests/misc/env-S.pl"
" tests/misc/kill.sh"
" tests/misc/nice.sh"
- " tests/misc/shred-passes.sh"
" tests/split/fail.sh"
- " tests/split/l-chunk.sh"
- " tests/dd/stats.sh"
" test-fdutimensat"
" test-futimens"
" test-linkat"
@@ -365,7 +362,15 @@ used to apply commands with arbitrarily long arguments.")
(("/bin/sh") (which "sh")))
(substitute* (find-files "tests" "\\.sh$")
(("#!/bin/sh") (string-append "#!" (which "sh"))))
- #t)))))
+ #t))
+ ,@(if (hurd-target?)
+ `((add-after 'unpack 'remove-tests
+ (lambda _
+ (substitute* "Makefile.in"
+ ;; this test hangs
+ (("^ *tests/misc/timeout-group.sh.*") ""))
+ #t)))
+ '()))))
(synopsis "Core GNU utilities (file, text, shell)")
(description
"GNU Coreutils package includes all of the basic command-line tools that