summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2020-06-09 23:35:56 -0700
committerChris Marusich <cmmarusich@gmail.com>2020-06-11 22:31:27 -0700
commita48a3f0640d76cb5e5945557c9aae6dabce39d93 (patch)
treedbb93cea241da0998eb69cee8628bbc9de702380 /gnu/packages/base.scm
parentcf0a721e98ca4df7b6ae55312fd77a11c2ed8e51 (diff)
downloadguix-patches-a48a3f0640d76cb5e5945557c9aae6dabce39d93.tar
guix-patches-a48a3f0640d76cb5e5945557c9aae6dabce39d93.tar.gz
gnu: sed: Make it build on SELinux-enabled kernels.
Fixes: <https://bugs.gnu.org/41498>. * gnu/packages/base.scm (sed)[origin][snippet]: New field. This adds a snippet, equivalent to the patch submitted upstream, which fixes an issue that prevents sed from building on SELinux-enabled kernels.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 325d2e2f0e..ecea6c97d4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
+;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -142,7 +143,19 @@ including, for example, recursive directory searching.")
".tar.gz"))
(sha256
(base32
- "0alqagh0nliymz23kfjg6g9w3cr086k0sfni56gi8fhzqwa3xksk"))))
+ "0alqagh0nliymz23kfjg6g9w3cr086k0sfni56gi8fhzqwa3xksk"))
+ ;; Remove this snippet once upstream releases a fixed version.
+ ;; This snippet changes Makefile.in, even though the upstream
+ ;; patch changes testsuite/local.mk, since we build sed from a
+ ;; release tarball. See: https://bugs.gnu.org/36150
+ (snippet
+ '(begin
+ (substitute* "Makefile.in"
+ (("^ abs_srcdir='\\$\\(abs_srcdir\\)'.*" previous-line)
+ (string-append
+ previous-line
+ " CONFIG_HEADER='$(CONFIG_HEADER)'\t\t\\\n")))))
+ (modules '((guix build utils)))))
(build-system gnu-build-system)
(synopsis "Stream editor")
(native-inputs