summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-11 16:56:36 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:48:15 +0200
commit9e1f5a263e4f6df4d075901c9b58a56f80c8b452 (patch)
tree1273d568ad16658a3876db10d2ceffe3335f46be /gnu/packages/base.scm
parentbb7c3d5aa3fceb08b0cc6403908bf8731d163745 (diff)
downloadguix-patches-9e1f5a263e4f6df4d075901c9b58a56f80c8b452.tar
guix-patches-9e1f5a263e4f6df4d075901c9b58a56f80c8b452.tar.gz
gnu: libcap: Make 'libcap/next' the default libcap.
* gnu/packages/avahi.scm (avahi)[inputs]: Refer to LIBCAP-2.31 instead of LIBCAP. * gnu/packages/base.scm (coreutils)[inputs]: Likewise. * gnu/packages/linux.scm (libcap): Rename to ... (libcap-2.31): ... this. (libcap/next): Rename to ... (libcap): ... this. (libcap/next): Define as deprecated alias for LIBCAP. (fakeroot)[inputs]: Change from LIBCAP/NEXT to LIBCAP. * gnu/packages/ntp.scm (chrony, ntp)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 1005899490..e8f7bb5f9c 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -324,7 +324,7 @@ used to apply commands with arbitrarily long arguments.")
,@(if (and (not (%current-target-system))
(member (%current-system)
(package-supported-systems libcap)))
- `(("libcap" ,libcap)) ;capability support in 'ls', etc.
+ `(("libcap" ,libcap-2.31)) ;capability support in 'ls', etc.
'())))
(native-inputs
;; Perl is needed to run tests in native builds, and to run the bundled