summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-04 22:10:06 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-04 22:10:06 +0200
commit949ed7aae1e9418ea99f569efe6cb03349485508 (patch)
tree5e2f2ff230c3387585a46cc47fcd4dc9c156f845 /gnu/packages/base.scm
parent9d9a8b079ab9d0a1b267992a54b77d9aabad69fd (diff)
downloadguix-patches-949ed7aae1e9418ea99f569efe6cb03349485508.tar
guix-patches-949ed7aae1e9418ea99f569efe6cb03349485508.tar.gz
gnu: glibc: Fix cross-compilation to aarch64-linux-gnu.
Fixes <https://bugs.gnu.org/49113>. Reported by Maxime Devos <maximedevos@telenet.be>. Previously, the cross-compiled libc.so linker script would read: OUTPUT_FORMAT(elf64-little) instead of: OUTPUT_FORMAT(elf64-littleaarch64) This is because glibc 2.33 runs "objdump -f" instead of "aarch64-linux-gnu-objdump -f" to determine the output format. * gnu/packages/patches/glibc-cross-objdump.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc)[source]: Use it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index edc4c4a427..67df8a9154 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -691,6 +691,7 @@ the store.")
"glibc-allow-kernel-2.6.32.patch"
"glibc-reinstate-prlimit64-fallback.patch"
"glibc-supported-locales.patch"
+ "glibc-cross-objdump.patch"
"glibc-hurd-clock_t_centiseconds.patch"
"glibc-hurd-clock_gettime_monotonic.patch"
"glibc-hurd-mach-print.patch"