summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-20 23:11:55 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-20 23:56:17 +0200
commit855bc05e118913ddc5d4c544a77a2f82c9df929c (patch)
tree13ca4605899343aa440c3bed9af65f2ac13c38da /gnu/packages/base.scm
parent3b49071fd1ee3e995900ea87fbabeea4d8cf86c6 (diff)
downloadguix-patches-855bc05e118913ddc5d4c544a77a2f82c9df929c.tar
guix-patches-855bc05e118913ddc5d4c544a77a2f82c9df929c.tar.gz
gnu: glibc: Add version 2.31.
* gnu/packages/base.scm (glibc-2.31): New variable. * gnu/system/locale.scm (%default-locale-libcs): Add it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index fb60e3c99b..99ba427ccb 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -956,6 +956,17 @@ with the Linux kernel.")
;; Below are old libc versions, which we use mostly to build locale data in
;; the old format (which the new libc cannot cope with.)
+(define-public glibc-2.31
+ (package
+ (inherit glibc)
+ (version "2.31")
+ (source (origin
+ (inherit (package-source glibc))
+ (uri (string-append "mirror://gnu/glibc/glibc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05zxkyz9bv3j9h0xyid1rhvh3klhsmrpkf3bcs6frvlgyr2gwilj"))))))
+
(define-public glibc-2.30
(package
(inherit glibc)