summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-03 08:10:47 -0400
committerLeo Famulari <leo@famulari.name>2017-11-04 10:32:30 -0400
commit75aea16fb0ef03424d8a366e29987aaba4c4cb64 (patch)
tree77a4ba029c6bbb33d826106b134680b04142ba80 /gnu/packages/base.scm
parentf9c3bd2e0183b777ad3794674a360222c62633b0 (diff)
downloadguix-patches-75aea16fb0ef03424d8a366e29987aaba4c4cb64.tar
guix-patches-75aea16fb0ef03424d8a366e29987aaba4c4cb64.tar.gz
gnu: tzdata-for-tests: Update to 2017c.
* gnu/packages/base.scm (tzdata-for-tests): Make it a 'hidden-package' and update to 2017c.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 109e9b698d..f6bc440a08 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1122,13 +1122,14 @@ reflect changes made by political bodies to time zone boundaries, UTC offsets,
and daylight-saving rules.")
(license public-domain)))
-;;; A "fixed" version of tzdata, which is used in the test suites of
-;;; glib and R. We can update this whenever we are able to rebuild
-;;; thousands of packages (for example, in a core-updates rebuild).
+;;; A "fixed" version of tzdata, which is used in the test suites of glib and R
+;;; and a few other places. We can update this whenever we are able to rebuild
+;;; thousands of packages (for example, in a core-updates rebuild). This package
+;;; will typically be obsolete and should never be referred to by a built
+;;; package.
(define-public tzdata-for-tests
- (package
- (inherit tzdata)
- (version "2017a")
+ (hidden-package (package (inherit tzdata)
+ (version "2017c")
(source
(origin
(method url-fetch)
@@ -1136,7 +1137,7 @@ and daylight-saving rules.")
"/releases/tzdata" version ".tar.gz"))
(sha256
(base32
- "1mmv4rvcs12lrvgghw4fidczvb69yv69cmzknghcvw1c196mqfnz"))))
+ "02yrrfj0p7ar885ja41ylijzbr8wc6kz6kzlw8c670i9m693ym6n"))))
(inputs `(("tzcode" ,(origin
(method url-fetch)
(uri (string-append
@@ -1144,7 +1145,7 @@ and daylight-saving rules.")
version ".tar.gz"))
(sha256
(base32
- "1b1q7gnlsh5hjgs5065pvajd37rmbc3k9b8cgzad1vcrifswdwh2"))))))))
+ "1dvrq0b2hz7cjqdyd7x21wpy4qcng3rvysr61ij0c2g64fyb9s41")))))))))
(define-public libiconv