summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2021-06-05 11:22:58 -0400
committerCarl Dong <contact@carldong.me>2021-06-11 16:37:52 -0400
commit6ba1058df0c4ce5611c2367531ae5c3cdc729ab4 (patch)
treecc40ce1011528ce559789e5b8ba60fcfcc634683 /gnu/packages/base.scm
parente4aa346d57f61956626032d0d1dfca6b3c96e06a (diff)
downloadguix-patches-6ba1058df0c4ce5611c2367531ae5c3cdc729ab4.tar
guix-patches-6ba1058df0c4ce5611c2367531ae5c3cdc729ab4.tar.gz
gnu: coreutils: Disable inotify-dir-recreate test
This test fails on filesystems where tail detects that it cannot use inotify safely. See https://issues.guix.gnu.org/47935 for more details. * gnu/packages/base.scm (coreutils)[phases]: Disable inotify-dir-recreate tests, quote Hurd substitute* call to reduce rebuilds.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d30299a7b6..edc4c4a427 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -378,13 +378,17 @@ used to apply commands with arbitrarily long arguments.")
(("/bin/sh") (which "sh")))
(substitute* (find-files "tests" "\\.sh$")
(("#!/bin/sh") (string-append "#!" (which "sh"))))))
- ,@(if (hurd-target?)
- `((add-after 'unpack 'remove-tests
- (lambda _
- (substitute* "Makefile.in"
+ (add-after 'unpack 'remove-tests
+ (lambda _
+ ,@(if (hurd-target?)
+ '((substitute* "Makefile.in"
;; this test hangs
- (("^ *tests/misc/timeout-group.sh.*") "")))))
- '()))))
+ (("^ *tests/misc/timeout-group.sh.*") "")))
+ '())
+ (substitute* "Makefile.in"
+ ;; fails on filesystems where inotify cannot be used,
+ ;; more info in #47935
+ (("^ *tests/tail-2/inotify-dir-recreate.sh.*") "")))))))
(synopsis "Core GNU utilities (file, text, shell)")
(description
"GNU Coreutils package includes all of the basic command-line tools that