summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-19 23:47:46 -0500
committerLeo Famulari <leo@famulari.name>2018-02-19 23:57:36 -0500
commit62868f124cf9443a43f4ea5867da692e32e77c58 (patch)
tree8d800607bf9f1208a6d8b863658c89bab67774e7 /gnu/packages/base.scm
parent3c747a080f015c9e62d76fc9b206b8393759e27a (diff)
downloadguix-patches-62868f124cf9443a43f4ea5867da692e32e77c58.tar
guix-patches-62868f124cf9443a43f4ea5867da692e32e77c58.tar.gz
gnu: tzdata: Preserve directory layout from before tzdata 2018a.
tzdata 2018a instroduced some changes to the build and installation procedures that commit e2832cdc3 failed to address. They are described in the NEWS file. This is a followup to commit e2832cdc3599e3bbc0362f9749835ffbae1b1944. * gnu/packages/base.scm (tzdata)[arguments]: Set TZDEFAULT. Remove the time-zone utility programs in a build phase.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 80fb0c17c2..f0964d7927 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1097,10 +1097,8 @@ command.")
(tmp (getenv "TMPDIR")))
(list (string-append "TOPDIR=" out)
(string-append "TZDIR=" out "/share/zoneinfo")
-
- ;; Discard zic, dump, and tzselect, already
- ;; provided by glibc.
- (string-append "ETCDIR=" tmp "/etc")
+ (string-append "TZDEFAULT=" out
+ "/share/zoneinfo/localtime")
;; Likewise for the C library routines.
(string-append "LIBDIR=" tmp "/lib")
@@ -1121,6 +1119,9 @@ command.")
(lambda* (#:key outputs #:allow-other-keys)
;; Move data in the right place.
(let ((out (assoc-ref outputs "out")))
+ ;; Discard zic, dump, and tzselect, already
+ ;; provided by glibc.
+ (delete-file-recursively (string-append out "/usr"))
(symlink (string-append out "/share/zoneinfo")
(string-append out "/share/zoneinfo/posix"))
(delete-file-recursively