summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-03-06 13:39:12 -0500
committerLeo Famulari <leo@famulari.name>2018-03-06 13:39:12 -0500
commit613ef763a52d7825f062eb7b58354504b64d2869 (patch)
treebee086914ed97aab1eaba25c325268e33e57c358 /gnu/packages/base.scm
parent86990eeda2a85acd3640059c0b681f1eddbacba0 (diff)
parent8a325748fb8c3709beb2c26966a3e3c86831f95e (diff)
downloadguix-patches-613ef763a52d7825f062eb7b58354504b64d2869.tar
guix-patches-613ef763a52d7825f062eb7b58354504b64d2869.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index b6c6dabae1..72dd9f8e13 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -537,6 +538,7 @@ store.")
;; Note: Always use a dot after the minor version since various places rely
;; on "version-major+minor" to determine where locales are found.
(version "2.26.105-g0890d5379c")
+ (replacement glibc-2.26-patched)
(source (origin
(method url-fetch)
(uri (string-append "https://alpha.gnu.org/gnu/guix/mirror/"
@@ -839,6 +841,15 @@ GLIBC/HURD for a Hurd host"
;; Below are old libc versions, which we use mostly to build locale data in
;; the old format (which the new libc cannot cope with.)
+(define glibc-2.26-patched
+ (package
+ (inherit glibc)
+ (replacement #f)
+ (source (origin
+ (inherit (package-source glibc))
+ (patches (cons (search-patch "glibc-allow-kernel-2.6.32.patch")
+ (origin-patches (package-source glibc))))))))
+
(define-public glibc-2.25
(package
(inherit glibc)