summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 01:26:17 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 05:02:06 -0400
commit44161fe16c28062275fe8226272c924283c34499 (patch)
tree5b5d2431ff806b6768c45b96c23376cc19f88f4a /gnu/packages/base.scm
parent5dc9ded15df969265d2d29e850bb293f04d0c4fc (diff)
downloadguix-patches-44161fe16c28062275fe8226272c924283c34499.tar
guix-patches-44161fe16c28062275fe8226272c924283c34499.tar.gz
gnu: glibc-utf8-locales: Use invoke instead of system*.
* gnu/packages/base.scm (glibc-utf8-locales)[arguments]: Use invoke and remove the vestigial result code plumbing.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d2afa24add..7569e30569 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -985,8 +985,7 @@ the 'share/locale' sub-directory of this package.")
(arguments
`(#:modules ((guix build utils))
#:builder (begin
- (use-modules (srfi srfi-1)
- (guix build utils))
+ (use-modules (guix build utils))
(let* ((libc (assoc-ref %build-inputs "glibc"))
(gzip (assoc-ref %build-inputs "gzip"))
@@ -997,27 +996,27 @@ the 'share/locale' sub-directory of this package.")
(setenv "PATH" (string-append libc "/bin:" gzip "/bin"))
(mkdir-p localedir)
- (every (lambda (locale)
- (define file
- ;; Use the "normalized codeset" by
- ;; default--e.g., "en_US.utf8".
- (string-append localedir "/" locale ".utf8"))
-
- (and (zero? (system* "localedef" "--no-archive"
- "--prefix" localedir
- "-i" locale
- "-f" "UTF-8" file))
- (begin
- ;; For backward compatibility with Guix
- ;; <= 0.8.3, add "xx_YY.UTF-8".
- (symlink (string-append locale ".utf8")
- (string-append localedir "/"
- locale ".UTF-8"))
- #t)))
-
- ;; These are the locales commonly used for
- ;; tests---e.g., in Guile's i18n tests.
- '("de_DE" "el_GR" "en_US" "fr_FR" "tr_TR"))))))
+ (for-each (lambda (locale)
+ (define file
+ ;; Use the "normalized codeset" by
+ ;; default--e.g., "en_US.utf8".
+ (string-append localedir "/" locale ".utf8"))
+
+ (invoke "localedef" "--no-archive"
+ "--prefix" localedir
+ "-i" locale
+ "-f" "UTF-8" file)
+
+ ;; For backward compatibility with Guix
+ ;; <= 0.8.3, add "xx_YY.UTF-8".
+ (symlink (string-append locale ".utf8")
+ (string-append localedir "/"
+ locale ".UTF-8")))
+
+ ;; These are the locales commonly used for
+ ;; tests---e.g., in Guile's i18n tests.
+ '("de_DE" "el_GR" "en_US" "fr_FR" "tr_TR"))
+ #t))))
(inputs `(("glibc" ,glibc)
("gzip" ,gzip)))
(synopsis "Small sample of UTF-8 locales")