summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-19 14:16:39 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-02 10:58:28 +0200
commit28cbc587d3588810d4370c7daa9693bde78a9a25 (patch)
treeb6e6eb27dcf23abcf7a7d6ca2dee9f35c4810326 /gnu/packages/base.scm
parent8c578a609478f808e4350c0140ca0b15c5bed0f2 (diff)
downloadguix-patches-28cbc587d3588810d4370c7daa9693bde78a9a25.tar
guix-patches-28cbc587d3588810d4370c7daa9693bde78a9a25.tar.gz
gnu: glibc: Upgrade to 2.22.
* gnu/packages/base.scm (glibc): Upgrade to 2.22. (coreutils-light): New variable. * gnu/packages/commencement.scm (locale-proof-package): New procedure. (%boot5-inputs): Add LD-WRAPPER, BINUTILS-FINAL, BASH-FINAL, GNU-MAKE, DIFFUTILS, FINDUTILS, COREUTILS-LIGHT (pass through 'new-libc-package'), and %BOOTSTRAP-COREUTILS&CO (passed through 'locale-proof-package'.)
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 5eb44eec36..0b775a3b76 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -284,6 +284,14 @@ functionality beyond that which is outlined in the POSIX standard.")
(license gpl3+)
(home-page "http://www.gnu.org/software/coreutils/")))
+(define-public coreutils-light
+ ;; Coreutils without its optional dependencies.
+ (package
+ (inherit coreutils)
+ (name "coreutils-light")
+ (outputs '("out"))
+ (inputs '())))
+
(define-public gnu-make
(package
(name "make")
@@ -438,14 +446,14 @@ store.")
(define-public glibc
(package
(name "glibc")
- (version "2.21")
+ (version "2.22")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/glibc/glibc-"
version ".tar.xz"))
(sha256
(base32
- "1f135546j34s9bfkydmx2nhh9vwxlx60jldi80zmsnln6wj3dsxf"))
+ "0j49682pm2nh4qbdw35bas82p1pgfnz4d2l7iwfyzvrvj0318wzb"))
(snippet
;; Disable 'ldconfig' and /etc/ld.so.cache. The latter is
;; required on LFS distros to avoid loading the distro's libc.so
@@ -471,7 +479,7 @@ store.")
#:parallel-build? #f
;; The libraries have an empty RUNPATH, but some, such as the versioned
- ;; libraries (libdl-2.21.so, etc.) have ld.so marked as NEEDED. Since
+ ;; libraries (libdl-2.22.so, etc.) have ld.so marked as NEEDED. Since
;; these libraries are always going to be found anyway, just skip
;; RUNPATH checks.
#:validate-runpath? #f