summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 10:07:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 11:47:09 -0500
commit276f40fdc349d2ad62582b23ea55e061b689cfc0 (patch)
tree8052d91aee78cf0d4317b41ec52134fde48fa5fb /gnu/packages/base.scm
parentb2f6b6f6b9df6bcc24794238e7e97357470af95d (diff)
parent6ba510d76d6847065be725e958718002f3b13c7a (diff)
downloadguix-patches-276f40fdc349d2ad62582b23ea55e061b689cfc0.tar
guix-patches-276f40fdc349d2ad62582b23ea55e061b689cfc0.tar.gz
Merge branch 'version-1.4.0'
With resolved conflicts in: gnu/packages/gnome.scm gnu/packages/openstack.scm gnu/packages/python-xyz.scm
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm33
1 files changed, 12 insertions, 21 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 8e21176081..0e49b6044c 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -521,10 +521,12 @@ change. GNU make offers many powerful extensions over the standard utility.")
(sha256
(base32 "1m3b2rdfv1dmdpd0bzg1hy7i8a2qng53szc6livyi3nh6101mz37"))
(patches (search-patches "binutils-loongson-workaround.patch"
- "binutils-2.37-file-descriptor-leak.patch"))))
+ "binutils-2.37-file-descriptor-leak.patch"
+ "binutils-CVE-2021-45078.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '(;; Add `-static-libgcc' to not retain a dependency
+ `(#:out-of-source? #t ;recommended in the README
+ #:configure-flags '(;; Add `-static-libgcc' to not retain a dependency
;; on GCC when bootstrapping.
"LDFLAGS=-static-libgcc"
@@ -543,7 +545,13 @@ change. GNU make offers many powerful extensions over the standard utility.")
;; Make sure 'ar' and 'ranlib' produce archives in a
;; deterministic fashion.
- "--enable-deterministic-archives")))
+ "--enable-deterministic-archives"
+
+ "--enable-64-bit-bfd"
+ "--enable-compressed-debug-sections=all"
+ "--enable-lto"
+ "--enable-separate-code"
+ "--enable-threads")))
(synopsis "Binary utilities: bfd gas gprof ld")
(description
@@ -556,23 +564,6 @@ included.")
(license gpl3+)
(home-page "https://www.gnu.org/software/binutils/")))
-;;; TODO: Merge into binutils on the next world rebuild.
-(define-public binutils-next
- (package/inherit binutils
- (name "binutils-next")
- (version "2.37")
- (arguments
- (substitute-keyword-arguments (package-arguments binutils)
- ((#:out-of-source? _ #f) ;recommended in the README
- #t)
- ((#:configure-flags flags)
- `(cons* "--enable-64-bit-bfd"
- "--enable-compressed-debug-sections=all"
- "--enable-lto"
- "--enable-separate-code"
- "--enable-threads"
- ,flags))))))
-
;; FIXME: ath9k-firmware-htc-binutils.patch do not apply on 2.34 because of a
;; big refactoring of xtensa-modules.c (commit 567607c11fbf7105 upstream).
;; Keep this version around until the patch is updated.
@@ -594,7 +585,7 @@ included.")
(properties '())))
(define-public binutils-gold
- (package/inherit binutils-next
+ (package/inherit binutils
(name "binutils-gold")
(arguments
(substitute-keyword-arguments (package-arguments binutils)