summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-10-12 14:01:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:29 -0500
commit24e5cf51847e50c7735e0090614093b799c0e30f (patch)
treebec2060b6d3c056c0a7431ae8acce81babf12022 /gnu/packages/base.scm
parent8b11b4a8297bffa8ee773e9dae763a80d3cde68d (diff)
downloadguix-patches-24e5cf51847e50c7735e0090614093b799c0e30f.tar
guix-patches-24e5cf51847e50c7735e0090614093b799c0e30f.tar.gz
gnu: glibc: Remove unneeded nscd patching.
This change had no effect already in glibc 2.29, which has proper versioning. * gnu/packages/base.scm (glibc)[arguments]: Remove obsolete 'nscd/nscd_stat.c' 'substitute*' statement. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 174af43917..9c45f524dc 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -830,15 +830,6 @@ the store.")
(string-append "#define _PATH_BSHELL \""
bash "/bin/sh\"\n")))
- ;; Nscd uses __DATE__ and __TIME__ to create a string to
- ;; make sure the client and server come from the same
- ;; libc. Use something deterministic instead.
- (substitute* "nscd/nscd_stat.c"
- (("static const char compilation\\[21\\] =.*$")
- (string-append
- "static const char compilation[21] = \""
- (string-take (basename out) 20) "\";\n")))
-
;; Make sure we don't retain a reference to the
;; bootstrap Perl.
(substitute* "malloc/mtrace.pl"