summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-07 03:53:38 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-14 09:24:15 +0100
commit11a5ffba7327250ebe7b67c777204e49858310bb (patch)
tree18e4b3cf0d6cd8d53b9f1f4e557f07f3ef602569 /gnu/packages/base.scm
parent4889be6ceb794d8c535d90df007e012ab7c2161e (diff)
downloadguix-patches-11a5ffba7327250ebe7b67c777204e49858310bb.tar
guix-patches-11a5ffba7327250ebe7b67c777204e49858310bb.tar.gz
gnu: coreutils: Remove libcap dependency for the Hurd.
* gnu/packages/linux.scm (libcap)[supported-systems]: Remove the Hurd. * gnu/packages/base.scm (coreutils)[inputs]: Include libcap only for supported systems. Fixes building on the Hurd.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f048e4b119..d74d304de1 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
;;; Copyright © 2014, 2015 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -303,11 +303,13 @@ used to apply commands with arbitrarily long arguments.")
(inputs `(("acl" ,acl) ; TODO: add SELinux
("gmp" ,gmp) ;bignums in 'expr', yay!
- ;; Drop the dependency on libcap when cross-compiling since it's
- ;; not quite cross-compilable.
- ,@(if (%current-target-system)
- '()
- `(("libcap" ,libcap))))) ;capability support is 'ls', etc.
+ ;; Do not use libcap when cross-compiling since it's not quite
+ ;; cross-compilable; and use it only for supported systems.
+ ,@(if (and (not (%current-target-system))
+ (not (member (%current-system)
+ (package-supported-systems libcap))))
+ `(("libcap" ,libcap)) ;capability support in 'ls', etc.
+ '())))
(native-inputs
;; Perl is needed to run tests in native builds, and to run the bundled
;; copy of help2man. However, don't pass it when cross-compiling since