summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-06 22:36:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-06 22:36:43 -0400
commitfb09818277d602e5f5b1c6ecde0b1944080291b7 (patch)
tree36c85cde9a61feff0327b8a4411fe320db531cc8 /gnu/packages/backup.scm
parentd879fd80c74371120a2cfa30e18a2e28dc02d31d (diff)
downloadguix-patches-fb09818277d602e5f5b1c6ecde0b1944080291b7.tar
guix-patches-fb09818277d602e5f5b1c6ecde0b1944080291b7.tar.gz
gnu: restic: Fix build.
This fixes a regression introduced by commit f42e4ebb56. * gnu/packages/backup.scm (restic)[arguments]: Remove "unpack-path" argument. [phases]{build, check, install, install-docs}: Update the working directory to "src/github.com/restic/restic".
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 9b26ead91e..a70cf52e1b 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -887,16 +887,13 @@ is like a time machine for your data. ")
(build-system go-build-system)
(arguments
`(#:import-path "github.com/restic/restic"
- #:unpack-path "github.com/restic"
;; We don't need to install the source code for end-user applications.
#:install-source? #f
#:phases
(modify-phases %standard-phases
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion (string-append
- "src/github.com/restic/restic-"
- ,version)
+ (with-directory-excursion "src/github.com/restic/restic"
;; Disable 'restic self-update'. It makes little sense in Guix.
(substitute* "build.go" (("selfupdate") ""))
(setenv "HOME" (getcwd)) ; for $HOME/.cache/go-build
@@ -904,9 +901,7 @@ is like a time machine for your data. ")
(replace 'check
(lambda _
- (with-directory-excursion (string-append
- "src/github.com/restic/restic-"
- ,version)
+ (with-directory-excursion "src/github.com/restic/restic"
;; Disable FUSE tests.
(setenv "RESTIC_TEST_FUSE" "0")
(invoke "go" "run" "build.go" "--test"))))
@@ -914,8 +909,7 @@ is like a time machine for your data. ")
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
- (src (string-append "src/github.com/restic/restic-"
- ,version)))
+ (src "src/github.com/restic/restic"))
(install-file (string-append src "/restic")
(string-append out "/bin"))
#t)))
@@ -925,8 +919,7 @@ is like a time machine for your data. ")
(let* ((out (assoc-ref outputs "out"))
(man "/share/man")
(man-section (string-append man "/man"))
- (src (string-append "src/github.com/restic/restic-"
- ,version "/doc/man/")))
+ (src "src/github.com/restic/restic/doc/man/"))
;; Install all the man pages to "out".
(for-each
(lambda (file)