summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 21:57:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:17:00 +0200
commitf32a1803f0c1e17bda7d7bd035fbbb1725d49c66 (patch)
treed7be03cf4c72c2f0850173b3bb8b5f9af5d8e39e /gnu/packages/backup.scm
parente252ec324d3bb79cb411bd1682c215792f5c8001 (diff)
downloadguix-patches-f32a1803f0c1e17bda7d7bd035fbbb1725d49c66.tar
guix-patches-f32a1803f0c1e17bda7d7bd035fbbb1725d49c66.tar.gz
gnu: obnam: Return #t from phases.
* gnu/packages/backup.scm (obnam)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index de96e6af21..9884f58fc3 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -683,17 +683,17 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
(replace 'check
(lambda _
(substitute* "obnamlib/vfs_local_tests.py"
- ;; Check for the nobody user instead of root
+ ;; Check for the nobody user instead of root.
(("self.fs.get_username\\(0\\), 'root'")
"self.fs.get_username(65534), 'nobody'")
- ;; Disable tests checking for root group
+ ;; Disable tests checking for root group.
(("self.fs.get_groupname\\(0\\)") "'root'"))
(substitute* "obnamlib/vfs_local.py"
- ;; Don't cover get_groupname function
+ ;; Don't cover get_groupname function.
(("def get_groupname\\(self, gid\\):")
"def get_groupname(self, gid): # pragma: no cover"))
- ;; Can't run network tests
- (zero? (system* "./check" "--unit-tests")))))))
+ ;; Can't run network tests.
+ (invoke "./check" "--unit-tests"))))))
(inputs
`(("python2-cliapp" ,python2-cliapp)
("python2-larch" ,python2-larch)