summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-01 23:36:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-02 00:36:02 +0100
commitd939b2955d8de2084f550a9063ce0c8006ecc4fa (patch)
tree049b784ccaca322ddce10004bf04c1cbfa701f32 /gnu/packages/backup.scm
parent658ef2ecdd72576f5183b43c770cd61c6be693e7 (diff)
downloadguix-patches-d939b2955d8de2084f550a9063ce0c8006ecc4fa.tar
guix-patches-d939b2955d8de2084f550a9063ce0c8006ecc4fa.tar.gz
gnu: rdup: Fix build, disable encryption.
* gnu/packages/backup.scm (nettle)[inputs]: Remove nettle. [arguments]: Add ‘disable-failing-tests’ phase.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 508ed9c7e4..0894cb38bf 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -308,11 +308,14 @@ random access nor for in-place modification.")
;; For tests.
("dejagnu" ,dejagnu)))
(inputs
+ ;; XXX Compiling with nettle (encryption) support requires patching out
+ ;; -Werror from GNUmakefile.in. Then, rdup-tr-{en,de}crypt tests fail:
+ ;; free(): invalid pointer
+ ;; ** rdup-tr: SIGPIPE received, exiting
`(("glib" ,glib)
("pcre" ,pcre)
("libarchive" ,libarchive)
- ("mcrypt" ,mcrypt)
- ("nettle" ,nettle)))
+ ("mcrypt" ,mcrypt)))
(arguments
`(#:parallel-build? #f ;race conditions
#:phases
@@ -328,6 +331,13 @@ random access nor for in-place modification.")
;; Avoid frivolous dependency on ‘which’ with a shell builtin.
(("which") "command -v"))
#t))
+ (add-before 'check 'disable-encryption-tests
+ (lambda _
+ (for-each delete-file
+ (list "testsuite/rdup/rdup.rdup-tr-crypt.exp"
+ "testsuite/rdup/rdup.rdup-tr-decrypt.exp"
+ "testsuite/rdup/rdup.rdup-tr-encrypt.exp"))
+ #t))
(add-before 'check 'pre-check
(lambda _
(setenv "HOME" (getcwd))