summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-04 17:49:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-04 22:19:33 +0200
commitd46fc636e6797a1601cc7a7a8eaf72759c495c89 (patch)
tree4e9447e133698a9ee3ad1550a8012fb4ab4f7844 /gnu/packages/backup.scm
parenta85d3fb07f66469f291f187658082b9b8b08bdc4 (diff)
downloadguix-patches-d46fc636e6797a1601cc7a7a8eaf72759c495c89.tar
guix-patches-d46fc636e6797a1601cc7a7a8eaf72759c495c89.tar.gz
gnu: borg: Update to 1.1.10.
* gnu/packages/backup.scm (borg): Update to 1.1.10. [source]: Remove upstreamed patch. Remove msgpack and broken references to it. [arguments]: Add ‘use-system-msgpack’ phase. * gnu/packages/patches/borg-fix-hard-link-preloading.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 70cc06c736..0bd894f958 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -511,15 +511,13 @@ detection, and lossless compression.")
(define-public borg
(package
(name "borg")
- (version "1.1.9")
+ (version "1.1.10")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
(sha256
- (base32
- "0x95nhv4h34m8cxycbwc4xdz350saaxlgh727b23bgn4ci7gh3vx"))
- (patches (search-patches "borg-fix-hard-link-preloading.patch"))
+ (base32 "1pp70p4n5kamvcbl4d8021ggrxhyykmg9isjg4yd3wags8b19d7g"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -541,7 +539,12 @@ detection, and lossless compression.")
;; Remove bundled shared libraries.
(with-directory-excursion "src/borg/algorithms"
(for-each delete-file-recursively
- (list "blake2" "lz4" "zstd")))
+ (list "blake2" "lz4" "msgpack" "zstd")))
+ ;; Purge some msgpack references from setup.py or the resulting
+ ;; sources will be unbuildable.
+ (substitute* "setup.py"
+ ((".*Extension\\('borg\\.algorithms\\.msgpack\\..*") "")
+ (("msgpack_packer_source, msgpack_unpacker_source") ""))
#t))))
(build-system python-build-system)
(arguments
@@ -565,6 +568,12 @@ detection, and lossless compression.")
;; HOME=/homeless-shelter.
(setenv "HOME" "/tmp")
#t)))
+ (add-after 'unpack 'use-system-msgpack
+ (lambda _
+ (substitute* "src/borg/helpers.py"
+ (("prefer_system_msgpack = False")
+ "prefer_system_msgpack = True"))
+ #t))
;; The tests need to be run after Borg is installed.
(delete 'check)
(add-after 'install 'check