summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-30 12:34:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-30 12:34:52 +0300
commitc820ec77aecc551914a51e3d0c0c7a84b244e7aa (patch)
treec25c154160e76bf7032ea11ed533179ea522d3bd /gnu/packages/backup.scm
parent3fced772e34cb332f6299411cd6501eadef760cb (diff)
downloadguix-patches-c820ec77aecc551914a51e3d0c0c7a84b244e7aa.tar
guix-patches-c820ec77aecc551914a51e3d0c0c7a84b244e7aa.tar.gz
gnu: libchop: Don't append to CPATH unconditionally.
* gnu/packages/backup.scm (libchop)[arguments]: Adjust 'set-libtirpc-include-path to return a valid CPATH.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index e07fab350a..de85c36b59 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
@@ -578,24 +578,23 @@ rsnapshot uses hard links to deduplicate identical files.")
(substitute* "configure"
(("GUILE=(.*)--variable bindir`" _ middle)
(string-append "GUILE=" middle
- "--variable bindir`/guile")))
- #t))
+ "--variable bindir`/guile")))))
(add-before 'build 'set-libtirpc-include-path
(lambda* (#:key inputs #:allow-other-keys)
;; Allow <rpc/rpc.h> & co. to be found.
- (let ((libtirpc (assoc-ref inputs "libtirpc")))
- (setenv "CPATH"
- (string-append (getenv "CPATH")
- ":" libtirpc
- "/include/tirpc"))
- #t)))
+ (let ((tirpc (string-append (assoc-ref inputs "libtirpc")
+ "/include/tirpc")))
+ (if (getenv "CPATH")
+ (setenv "CPATH"
+ (string-append (getenv "CPATH")
+ ":" tirpc))
+ (setenv "CPATH" tirpc)))))
(add-before 'check 'skip-test
(lambda _
;; XXX: This test fails (1) because current GnuTLS no
;; longer supports OpenPGP authentication, and (2) for
;; some obscure reason. Better skip it.
- (setenv "XFAIL_TESTS" "utils/block-server")
- #t)))))
+ (setenv "XFAIL_TESTS" "utils/block-server"))))))
(native-inputs
`(("guile" ,guile-2.0)
("gperf" ,gperf-3.0) ;see <https://bugs.gnu.org/32382>