summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-16 12:10:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-16 13:02:59 +0200
commit7d728270abe6df469b9dd1bb96c09875c8d401e9 (patch)
treeaa0788c7bd16fda4085ad602aa83ffef69deb81e /gnu/packages/backup.scm
parent4def7dac231a47a7b04d87616130cc57a1d573c4 (diff)
downloadguix-patches-7d728270abe6df469b9dd1bb96c09875c8d401e9.tar
guix-patches-7d728270abe6df469b9dd1bb96c09875c8d401e9.tar.gz
gnu: btar: Cross compile.
* gnu/packages/backup.scm (btar)[arguments]: Use cc-for-target in make-flags.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 15b1eb17c7..c145a2f756 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
@@ -392,7 +392,7 @@ list and implement the backup strategy.")
`(("librsync" ,librsync-0.9)))
(arguments
`(#:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
- "CC=gcc")
+ ,(string-append "CC=" ,(cc-for-target)))
#:tests? #f ;test input not distributed
#:phases
;; no configure phase