summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-29 23:15:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-30 03:51:00 +0200
commit7bb7920f64a871eadd8e76687f72673ef2298746 (patch)
treeeb7b011e8c60425abe07d4782638865d6a0d338d /gnu/packages/backup.scm
parent99e0fb24fb7984304f139cb02b31643216642491 (diff)
downloadguix-patches-7bb7920f64a871eadd8e76687f72673ef2298746.tar
guix-patches-7bb7920f64a871eadd8e76687f72673ef2298746.tar.gz
gnu: duplicity: Update to 0.7.18.1.
* gnu/packages/backup.scm (duplicity): Update to 0.7.18.1. [arguments]: Remove upstreamed '--ignore-mdc-error' kluge. Rename 'patch-source' phase to 'use-store-file-names'.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index b36bb74f6f..bd4a177ecd 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -67,7 +67,7 @@
(define-public duplicity
(package
(name "duplicity")
- (version "0.7.18")
+ (version "0.7.18.1")
(source
(origin
(method url-fetch)
@@ -77,7 +77,7 @@
version ".tar.gz"))
(sha256
(base32
- "1qlika4l1k1nx8zr657ihcy0yzr1c1cdnjlbs325l5krvc3zbc5b"))))
+ "17c0203y5qz9w8iyhs26l44qf6a1vp26b5ykz1ypdr2kv6g02df9"))))
(build-system python-build-system)
(native-inputs
`(("util-linux" ,util-linux) ; setsid command, for the tests
@@ -99,21 +99,12 @@
#:test-target "test"
#:phases
(modify-phases %standard-phases
- (add-before 'build 'patch-source
+ (add-before 'build 'use-store-file-names
(lambda* (#:key inputs #:allow-other-keys)
- ;; Embed gpg store name.
(substitute* "duplicity/gpginterface.py"
(("self.call = 'gpg'")
(string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))
- ;; This matches up with an unreleased upstream fix, it should be
- ;; removed when the package is updated.
- ;; https://bazaar.launchpad.net/~duplicity-team/duplicity/0.8-series/revision/1308
- (substitute* "duplicity/gpg.py"
- (("--no-secmem-warning'\\)")
- "--no-secmem-warning')
- gnupg.options.extra_args.append('--ignore-mdc-error')"))
-
(substitute* '("testing/functional/__init__.py"
"testing/overrides/bin/lftp")
(("/bin/sh") (which "sh")))