summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 00:58:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 05:24:18 +0100
commit70a229aafec9e36bc6c82041ceee71e1454d6530 (patch)
treeb5be2dea5bd1317bac83281698d13e3c1a6ab6d4 /gnu/packages/backup.scm
parente3c9860ab905ce035c8d71d5044558673bc99654 (diff)
downloadguix-patches-70a229aafec9e36bc6c82041ceee71e1454d6530.tar
guix-patches-70a229aafec9e36bc6c82041ceee71e1454d6530.tar.gz
gnu: snapraid: ‘Fix’ build.
* gnu/packages/backup.scm (snapraid)[arguments]: Remove "--enable-valgrind" from #:configure-flags. [native-inputs]: Remove valgrind.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index b3bd099e37..08fbebe7b0 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -399,8 +399,10 @@ list and implement the backup strategy.")
(build-system gnu-build-system)
(arguments
(list #:configure-flags
- #~(list "--enable-valgrind"
- "--with-blkid")
+ ;; XXX --enable-valgrind fails with ‘A must-be-redirected function
+ ;; whose name matches the pattern: strlen in an object with soname
+ ;; matching: ld-linux-x86-64.so.2 was not found […]’; used to work.
+ #~(list "--with-blkid")
#:phases
#~(modify-phases %standard-phases
(add-before 'bootstrap 'set-version
@@ -408,9 +410,7 @@ list and implement the backup strategy.")
(setenv "VERSION" #$version)
(patch-shebang "autover.sh"))))))
(native-inputs
- (list automake autoconf
- ;; For the tests.
- valgrind))
+ (list automake autoconf))
(inputs
(list `(,util-linux "lib"))) ; libblkid
(home-page "https://www.snapraid.it/")