summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-23 16:49:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-23 23:51:22 +0200
commit5d26ba7ee3c07fad1f4054396eaeec6f992a9eac (patch)
treef2c401f2c1345a3014d46ae23dbea71d058b5e0e /gnu/packages/backup.scm
parent4ba0f3b597f7099c5a780cad45b86c2e384507ea (diff)
downloadguix-patches-5d26ba7ee3c07fad1f4054396eaeec6f992a9eac.tar
guix-patches-5d26ba7ee3c07fad1f4054396eaeec6f992a9eac.tar.gz
gnu: burp: Update to 2.3.30.
* gnu/packages/backup.scm (burp): Update to 2.3.30. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 7a1fd142bf..532cb66c70 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1067,14 +1067,16 @@ interractive mode.")
(define-public burp
(package
(name "burp")
- (version "2.3.28")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/burp/burp-" version
- "/burp-" version ".tar.bz2"))
- (sha256
- (base32
- "18f8cjsb87skabvz4cl5pdln35qmim7x686js1xzpld6wyl9kv2k"))))
+ (version "2.3.30")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grke/burp")
+ (commit version)))
+ (sha256
+ (base32 "1f9i5d415psbr03fqd47p162qy25sypra1w8w16ym6jk1pvdjsgx"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1092,7 +1094,9 @@ interractive mode.")
("uthash" ,uthash)
("zlib" ,zlib)))
(native-inputs
- `(("check" ,check)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("check" ,check)
("pkg-config" ,pkg-config)))
(home-page "https://burp.grke.org")
(synopsis "Differential backup and restore")