summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-08-08 08:25:05 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-08-08 20:56:32 +0300
commit4976ebddf1a4735ee12808083876f573121993bf (patch)
tree1894aefc91dfe4b2750043a7c2aea3d054d6d4c0 /gnu/packages/backup.scm
parentb5b610af5d6e5bd72381f79f526fa38d411686e0 (diff)
downloadguix-patches-4976ebddf1a4735ee12808083876f573121993bf.tar
guix-patches-4976ebddf1a4735ee12808083876f573121993bf.tar.gz
gnu: restic: Fix tests.
* gnu/packages/backup.scm (restic)[arguments]: Replace 'check' phase.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 0733d9c345..251dadf84b 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -862,6 +862,15 @@ is like a time machine for your data. ")
,version)
(invoke "go" "run" "build.go"))))
+ (replace 'check
+ (lambda _
+ (with-directory-excursion (string-append
+ "src/github.com/restic/restic-"
+ ,version)
+ ;; unexpected error: fusermount: exit status 1
+ (delete-file "cmd/restic/integration_fuse_test.go")
+ (invoke "go" "run" "build.go" "--test"))))
+
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))