summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-05 22:54:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-05 22:56:49 -0400
commit362a1cc3fb50c67ed4249b97827dbffdbdace766 (patch)
treee99d71e3d682799e214ab25fa3bfa6d6b4176b5f /gnu/packages/backup.scm
parent1273548f4facefa379ae3607b47891959c42c13d (diff)
downloadguix-patches-362a1cc3fb50c67ed4249b97827dbffdbdace766.tar
guix-patches-362a1cc3fb50c67ed4249b97827dbffdbdace766.tar.gz
gnu: restic: Have the custom check phase honor TESTS?.
* gnu/packages/backup.scm (restic)[phases]{check}: Honor TESTS?.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index d8d8728a14..b35dbe4b76 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -948,11 +948,12 @@ is like a time machine for your data. ")
(invoke "go" "run" "build.go"))))
(replace 'check
- (lambda _
- (with-directory-excursion "src/github.com/restic/restic"
- ;; Disable FUSE tests.
- (setenv "RESTIC_TEST_FUSE" "0")
- (invoke "go" "run" "build.go" "--test"))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "src/github.com/restic/restic"
+ ;; Disable FUSE tests.
+ (setenv "RESTIC_TEST_FUSE" "0")
+ (invoke "go" "run" "build.go" "--test")))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)