summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:54:53 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:42:38 -0400
commit1a3aa5bab2f9ceb657c862017af62fa295834f98 (patch)
treed79402dc5d4d59017c3c69179389d7a0ea233e76 /gnu/packages/backup.scm
parent859e8873d08f43787f02d4ce4b2b8482a3cf0fa7 (diff)
downloadguix-patches-1a3aa5bab2f9ceb657c862017af62fa295834f98.tar
guix-patches-1a3aa5bab2f9ceb657c862017af62fa295834f98.tar.gz
gnu: libarchive: Use invoke.
* gnu/packages/backup.scm (libarchive)[arguments]: Use invoke and remove vestigial plumbing from the check phase.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 628c39a6eb..d34c14d376 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -226,12 +227,11 @@ backups (called chunks) to allow easy burning to CD/DVD.")
;; the chroot's /etc/passwd doesn't have it. Turn off those tests.
;;
;; The tests allow one to disable tests matching a globbing pattern.
- (and (zero? (system* "make"
- "libarchive_test" "bsdcpio_test" "bsdtar_test"))
- ;; XXX: This glob disables too much.
- (zero? (system* "./libarchive_test" "^test_*_disk*"))
- (zero? (system* "./bsdcpio_test" "^test_owner_parse"))
- (zero? (system* "./bsdtar_test"))))))
+ (invoke "make" "libarchive_test" "bsdcpio_test" "bsdtar_test")
+ ;; XXX: This glob disables too much.
+ (invoke "./libarchive_test" "^test_*_disk*")
+ (invoke "./bsdcpio_test" "^test_owner_parse")
+ (invoke "./bsdtar_test"))))
;; libarchive/test/test_write_format_gnutar_filenames.c needs to be
;; compiled with C99 or C11 or a gnu variant.
#:configure-flags '("CFLAGS=-O2 -g -std=c99")))