summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-17 22:33:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-17 23:27:40 -0400
commit0ac95b4490f2b661370b29980f6f01d28d03db6a (patch)
tree9f73bd7d847f52d8a32a7c8bd80d78e7b38bf8af /gnu/packages/backup.scm
parentfd449608eb9016fb705eebbea784901b0242cbf2 (diff)
downloadguix-patches-0ac95b4490f2b661370b29980f6f01d28d03db6a.tar
guix-patches-0ac95b4490f2b661370b29980f6f01d28d03db6a.tar.gz
gnu: disarchive: Fix build when cross-compiling.
This follows commit 0b1f70d1a7, which inadvertently broke the build of Guix for i586-pc-gnu (Hurd). * gnu/packages/patches/disarchive-cross-compilation.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/backup.scm (disarchive)[source]: Apply it. [phases]{delete-configure}: New phase. [native-inputs]: Add guile-3.0 and guile-gcrypt.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index f3d51e9983..5e0009472e 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1103,12 +1103,20 @@ backup.")
"disarchive-" version ".tar.gz"))
(sha256
(base32
- "1jypk0gdwxqbqxiblww863nzq0kwnc676q68j32sprqd7ilnq02s"))))
+ "1jypk0gdwxqbqxiblww863nzq0kwnc676q68j32sprqd7ilnq02s"))
+ (patches (search-patches "disarchive-cross-compilation.patch"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'delete-configure
+ (lambda _
+ (delete-file "configure"))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("pkg-config" ,pkg-config)
+ ("guile" ,guile-3.0) ;for cross-compilation
+ ("guile-gcrypt" ,guile-gcrypt)
("guile-quickcheck" ,guile-quickcheck)))
(inputs
`(("guile" ,guile-3.0)